PAT 1065 A+B and C (64bit)

1065 A+B and C (64bit) (20 分)
 

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main(){
    int t;
    cin >> t;
    int cnt = 1;
    while(t--){
        bool flag=1;
        ll a,b,c;cin >> a >> b >> c;
        ll res = a+b;
        if(a>0&&b>0&&res<0){ // 正溢出
            flag=1;
        }
        else if(a<0&&b<0&&res>=0){ //负溢出是大于等于0
            flag=0;
        }
        else if(res > c){
            flag=1;
        }
        else if(res <= c){
            flag=0;
        }
        if(flag){
            printf("Case #%d: true\n",cnt++);
        }
        else{
            printf("Case #%d: false\n",cnt++);
        }
    }


    return 0;
}

基本想不到溢出吧。。还有注意>=0;

 

猜你喜欢

转载自www.cnblogs.com/cunyusup/p/10772080.html