HDU-1556(树状数组-区间更新 单点查询)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1556

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

 

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

 

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

 

Sample Input

扫描二维码关注公众号,回复: 2404607 查看本文章
 

3 1 1 2 2 3 3 3 1 1 1 2 1 3 0

 

Sample Output

 

1 1 1 3 2 1

 

Author

8600

很模板的一道树状数组的区间更新定点查询的例题:

套上模板。

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
const int N=100100;

int tree[N];
int n;

int lowbit(int x)
{
	return x&(-x);
}

void updata(int x,int num)
{
	while(x<=N)
	{
		tree[x]=tree[x]+num;
		x=x+lowbit(x);
	}
}

int Query(int i)
{
	int sum=0;
	while(i>0)
	{
		sum=sum+tree[i];
		i=i-lowbit(i);
	}
	return sum;
}

int main()
{
	int n;
	while(cin>>n&&n!=0)
	{
		clean(tree,0);
		for(int i=1;i<=n;++i)
		{
			int a,b;
			cin>>a>>b;
            //单点查询的时候只需要在区间内一次更新就行了
			updata(a,1);//a开始后面的都涂上 
			updata(b+1,-1);//b开始后面的都不图 
		}
		for(int i=1;i<n;++i)
			cout<<Query(i)<<" ";
		cout<<Query(n)<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/81170442
今日推荐