HDU 1566 Color the ball(树状数组 区间更新,单点查询)

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3

1 1

2 2

3 3

3

1 1

1 2

1 3

0

Sample Output

1 1 1

3 2 1

分析:给定一个序列和n次操作a,b,每次从a到b对应的序列值加1;再输出操作完后的序列。

#include <iostream>
#include <cstring>
using namespace std;
typedef long long ll;
const int MAXN = 1e5+10;
int c[MAXN], n;
int lowbit(int x) {
	return (-x)&x;
}
ll sum(int k) {
	ll s = 0;
	while(k > 0) {
		s += c[k];
		k -= lowbit(k);
	}
	return s;
}
void update(int i, int x) {
	while(i <= n) {
		c[i] += x;
		i += lowbit(i);
	}
}
int main() {
	int a, b, t;
	while(cin>>n,n) {
		for(int i = 1; i <= n; i++) {
			c[i] = 0;
		}
		t = n;
		while(t--) {
			cin>>a>>b;
			update(a, 1);
			update(b + 1, -1);
		}
		for(int i = 1; i <= n; i++) {
			if(i == n) {
				cout<<sum(i)<<endl;
			} else {
				cout<<sum(i)<<" ";
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/adusts/article/details/81210231
今日推荐