Color the ball (树状数组,区间更新,单点查询)

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。 
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1
#include<iostream>
#include<cstring> 
int N;
using namespace std;
int c[100010];
int lowbit(int x)//求k 
{
	return x&(-x);
}
void Update(int i,int x)
{
	while(i<=N)
	{
		c[i]+=x;
		i+=lowbit(i);
	}
}
int Query(int n)
{
	int sum=0;
	while(n>0)
	{
		sum+=c[n];
		n-=lowbit(n);
	}
	return sum;
}
int main()
{
	int a,b,i,j;
	while(cin>>N&&N)
	{	
	    memset(c,0,sizeof(c));
	    for(i=0;i<N;i++)   
		{
			cin>>a>>b;
			Update(a,1);
			Update(b+1,(-1));  
		}
		for(i=1;i<N;i++)
		cout<<Query(i)<<" ";
		cout<<Query(N)<<endl;
	}
} 

猜你喜欢

转载自blog.csdn.net/daoshen1314/article/details/83592569
今日推荐