hdu1556-Color the ball(树状数组-区间更新单点查询)

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1556

题目原文:

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31334    Accepted Submission(s): 15160


 

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

 

 

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

 

 

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

 

 

Sample Input

 

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

 

 

Sample Output

 

1 1 1
3 2 1

解题思路:

        利用树状数组区间更新单点查询的方法,可以参考上一篇 hdu4325-Flowers

AC代码:

#include <cstdio>
#include <cstring>
using namespace std;

const int N = int(1e5 + 5);

int g_dif[N];
int g_n;

void init()
{
    memset(g_dif, 0, sizeof(g_dif));
}

int lowbit(const int &x)
{
    return x & (-x);
}

void update(int idx, const int &difVal)
{
    while (idx <= g_n)
    {
        g_dif[idx] += difVal;
        idx += lowbit(idx);
    }
}

void update(const int &left, const int &right, const int &difVal)
{
    update(left, difVal);
    update(right + 1, -difVal);
}

int calcSum(int endIdx)
{
    int s = 0;
    while (endIdx > 0)
    {
        s += g_dif[endIdx];
        endIdx -= lowbit(endIdx);
    }
    return s;
}

int main()
{
    int i, a, b;
    while (scanf("%d", &g_n), g_n)
    {
        init();
        for (i = 1; i <= g_n; i++)
        {
            scanf("%d%d", &a, &b);
            update(a, b, 1);
        }
        for (i = 1; i <= g_n; i++)
        {
            if (i != 1) printf(" ");
            printf("%d", calcSum(i));
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41645983/article/details/88764015
今日推荐