PAT (Advanced Level) Practice A1049 Counting Ones (30 分)(C++)(甲级)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86590157

1049 Counting Ones (30 分)
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2 ​30).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:

12
Sample Output:

5

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int pow(int x, int y)//求幂
{
    if(!y) return 1;
    return x*pow(x, y-1);
}

int main()
{
    int S[50] = {0};
    int N, cnt = 0, top = -1, temp_cnt = 1;
    scanf("%d", &N);
    int M = N;//把N复制
    while(N)//把N拆分
    {
        S[++top] = N%10;
        N /= 10;
    }
    N = M;//重新赋给N
    for(int i=0; i<=top; i++)
    {
        if(!S[i]) cnt += N/10 * pow(10, i);//该位为0,则存在N/10 * 10^i个1
        else if(S[i] == 1) cnt += N/10 * pow(10, i) + M%pow(10, i) + 1;//该位为1,则还需要考虑其后面的那部分
        else cnt += (N/10+1) * pow(10, i);//该位大于1,则(N/10+1) * 10^i个1
        N /= 10;
    }
    printf("%d", cnt);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86590157