PAT A1049 Counting Ones (30分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805430595731456

题目描述
The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

输入
Each input file contains one test case which gives the positive N (≤2^​30​​ ).

输出
For each test case, print the number of 1’s in one line.

样例输入
12

样例输出
5

代码

#include <cstdio>

int main() {
	int n, a = 1, ans = 0;
	int left, right, now;
	scanf("%d", &n);
	while(n / a != 0) {
		left = n / (a * 10);
		now = n / a % 10;
		right = n % a;
		if(now == 0)
			ans += left * a;
		else if(now == 1)
			ans += left * a + right + 1;
		else
			ans += (left + 1) * a;
		a *= 10;
	}
	printf("%d", ans);
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104928856