Python实现Pat 1049. Counting Ones (30)

题目

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:
12
Sample Output:
5

解答,会超时

#直接检查每一个数值中1的个数
N=int(input())
sum=0
for i in range(N+1):
    si=str(i)
    sir=si.replace('1','')
    sum+=len(si)-len(sir)
print (sum)

这里写图片描述

猜你喜欢

转载自blog.csdn.net/ychanty/article/details/78757644