【PAT】A1010 Radix (25point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 400 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1010 Radix (25point(s))

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​ , your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

Code

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <string>
using namespace std;
long long Pto10(string n, int p){   // p进制转化为10进制
    long long result=0,product=1;
    for(long long i=n.size()-1;i>=0;i--){
        if(n[i]>='0'&&n[i]<='9')    result+=(n[i]-'0')*product;
        if(n[i]>='a'&&n[i]<='z')    result+=(n[i]-'a'+10)*product;
        product*=p;
    }
    return result;
}
int main(){
    string n1,n2;
    long long tag,radix;
	cin>>n1>>n2>>tag>>radix;
	if(tag==2)  swap(n1,n2);  // 保证n1存已知进制的数
	long long num1=Pto10(n1,radix),num2,low=2,high,mid;
	for(int i=0;i<n2.size();i++){	// 找到二分查找对应进制的下限
        if(n2[i]>='0'&&n2[i]<='9')    low=max((long long)n2[i]-'0'+1,low);
        else    low=max((long long)n2[i]-'a'+10+1,low);
	}
	high = max(low,num1);		// 找到二分查找对应进制的上限
	while(low<=high){   // 二分找符合的进制
        mid=(low+high)/2;
        num2=Pto10(n2,mid);
        if(num1==num2){
            printf("%d\n",mid);
            return 0;
        }
        else if(num2>num1||num2<0)  high=mid-1;
        else    low=mid+1;
	}
    printf("Impossible\n");
	return 0;
}

Analysis

-已知4个数。分别为n1、n2、tag、radix。如果tag=1,则radix表示n1的进制。如果tag=2,则radix表示n2的进制。

-求另一个数给出进制的数的什么进制。如:tag=1,则给出进制的数为n1,另一个数为n2。

-注意,最高能表示的进制不止是36进制。

-如何确定进制的上下限
下限:n2(另一个数)的最大位的值+1。如:若n2中最大位为z,则下限为36。
上限:n1(给出进制的数)的值+1。如:n1用10进制表示的数为12345,则上限为12346。

重要参考https://blog.csdn.net/Joyceyang_999/article/details/81908299

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103776973