航电oj1004:Let the Balloon Rise

版权声明:就是开个版权玩一下 https://blog.csdn.net/qq_41997479/article/details/86558222

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 155265    Accepted Submission(s): 61685


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.


Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.


Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.


Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0


Sample Output

red

pink


解题思路:

先建立一个气球的颜色结构,该结构存放颜色单词的每一个字符char a[1000],之后就好操作了,我之前就一直纠结C++的数组怎么在每个a[i]中存入字符串,现在这个方法学习到了,自己创建结构。

代码如下:

#include<math.h>
#include<iostream>
#include<string.h>
using namespace std;

struct colour{
	char a[1000];
};

int main() {
	int num;
	struct colour ball[1000];
	int max ;
	int count ;
	int flag;
	while (~scanf("%d", &num)&&num)
	{
		max = 0;
		getchar();//在输入连续字符串时,过滤掉回车换行符'\n'
		if (num > 0&&num <= 1000)
		{
			for (int i = 0; i < num; i++)
			{
				cin >> ball[i].a;
			}
			for (int i = 0; i < num; i++)
			{
				count = 0;
				for (int j = 0; j < num; j++)
				{
					if (strcmp(ball[i].a, ball[j].a) == 0)
						count++;
					if (count > max)
					{
						max = count;
						flag = i;
					}
						
				}
			}
			cout << ball[flag].a<<endl;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41997479/article/details/86558222