POJ - 1088 滑雪 【DP】【DFS】

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int h[105][105], b[105][105];
int r, c;

int dfs(int x, int y)
{
    int ans = 1;
    if (b[x][y] > 0)
        return b[x][y];

    if (x-1 >= 1 && h[x][y]>h[x-1][y]) // up
        ans = max(dfs(x-1, y)+1, ans);

    if (x+1 <= r && h[x][y]>h[x+1][y]) // down
        ans = max(dfs(x+1, y)+1, ans);

    if (y-1 >= 1 && h[x][y]>h[x][y-1]) // left
        ans = max(dfs(x, y-1)+1, ans);

    if (y+1 <= c && h[x][y]>h[x][y+1]) // right
        ans = max(dfs(x, y+1)+1, ans);

    b[x][y] = ans;
    return b[x][y];
}

int main()
{
    scanf("%d %d", &r, &c);
    for (int i = 1; i <= r; i++)
        for (int j = 1; j <= c; j++)
            scanf("%d", &h[i][j]);

    memset(b, 0, sizeof(b));
    for (int i = 1; i <= r; i++) {
        for (int j = 1; j <= c; j++) {
            if (b[i][j] > 0)
                continue;
            dfs(i, j);
        }
    }
    int m = b[1][0];
    for (int i = 1; i <= r; i++)
        for (int j = 1; j <= c; j++)
            m = max(m, b[i][j]);

    printf("%d",m);
    return 0;
}
发布了329 篇原创文章 · 获赞 342 · 访问量 17万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/105419383
今日推荐