FatMouse and Cheese ————记忆化搜索

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37


题意:
-老鼠在 N N 的棋盘上跳
-老鼠的起始位置是 ( 0 , 0 )
-每次只能往棋盘上分值比较大的点跳,每跳到一个点就获得那个点对应的分值
-最多只能在行或者列上跳的距离是   k

问老鼠能够获得的最大分值


#include<bits/stdc++.h>
using namespace std;
const int MAXN=107;
int a[MAXN][MAXN];
int dp[MAXN][MAXN];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
int n,k;

bool check(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<n)    return true;
    else    return false;
}
int dfs(int x,int y)
{
    if(dp[x][y])    return dp[x][y];
    int ans=0;
    for(int i=0;i<4;i++)
        for(int j=1;j<=k;j++)
        {
            int nx=x+j*dx[i];
            int ny=y+j*dy[i];
            if(check(nx,ny)&&a[x][y]<a[nx][ny])
                ans=max(ans,dfs(nx,ny));
        }
    dp[x][y]=ans+a[x][y];
    return dp[x][y];
}

int main()
{
    while(~scanf("%d %d",&n,&k))
    {
        if(n==-1&&k==-1)    break;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&a[i][j]);
        cout<<dfs(0,0)<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81563371
今日推荐