DP专题-------P - FatMouse and Cheese 记忆化搜索

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37

题意:给一个矩阵,以及每一步能够走的步数,求出老鼠能够吃到的最多的奶酪数,(前一个格子的奶酪数少于后一个格子的)
思路:采用记忆化搜索,dp[i][j]表示在(i,j)点的时候的最大奶酪数

这道题的状态转移有好多个,来自当前坐标(i,j)走的k步的坐标转移过来的;
所以用递推写不太好写,所以用dfs记忆化搜索,找到所有状态

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second

int dp[105][105];
int mk[105][105];
int n,k;
bool judge(int i ,int j)
{
    if(i < 0 || j < 0)
        return false;
    if(i >= n || j >= n)
        return false;
    return true;
}
int col[5] = {-1,1,0,0};
int con[5] = {0,0,-1,1};

int dfs(int sx,int sy)
{
    if(dp[sx][sy] != -1){
        return dp[sx][sy];
    }
    int MAX = 0;
    for(int i = 0;i < 4;++i){
        for(int j = 1;j <= k;++j){
            int tx = sx + col[i] * j;
            int ty = sy + con[i] * j;
            if(!judge(tx,ty) || mk[sx][sy] >= mk[tx][ty])
                continue;
            int tmp = dfs(tx,ty);
            MAX = max(MAX,tmp);
        }
    }
    dp[sx][sy] = mk[sx][sy] + MAX;
    return dp[sx][sy];
}

int main()
{
    while(~scanf("%d %d",&n,&k)){
        if(n == -1 && k == -1)
            break;
        for(int i = 0;i < n;++i){
            for(int j = 0;j < n;++j){
                scanf("%d",&mk[i][j]);
            }
        }
        memset(dp,-1,sizeof(dp));
        printf("%d\n",dfs(0,0));
    }
    return 0;
}

发布了269 篇原创文章 · 获赞 33 · 访问量 8万+

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/89188409