并查集-POJ1182食物链(带权并查集)

POJ1182食物链

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是”1 X Y”,表示X和Y是同类。
第二种说法是”2 X Y”,表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5

Sample Output

3

思路

带权并查集
用一个rela代表该节点与根节点的关系
向量偏移
root[x]->root[y] = root[x]->x + x->y + y->root[y]

AC代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 50010

struct node
{
    int fa;
    int rela;
}p[N];

int ifind(int x)
{
    int tmp;
    if(x == p[x].fa)
        return x;
    tmp = p[x].fa;
    p[x].fa = ifind(tmp);
    p[x].rela = (p[x].rela + p[tmp].rela) % 3;
    return p[x].fa;
}

int main()
{
    int n, k;
    int d, x, y;
    int sum = 0;
    scanf("%d%d", &n, &k);
    for(int i = 1; i <= n; ++i)
    {
        p[i].fa = i;
        p[i].rela = 0;
    }
    for(int i = 1; i <= k; ++i)
    {
        scanf("%d%d%d", &d, &x, &y);
        if(x > n || y > n)
        {
            sum++;
            continue;
        }
        if(d == 2 && x == y) //条件3
        {
            sum++;
            continue;
        }
        int fx = ifind(x);
        int fy = ifind(y);
        if(fx != fy) 
        {
            p[fy].fa = fx;
            p[fy].rela = (3 + (d - 1) +p[x].rela - p[y].rela) % 3;
        }
        else
        {
            if(d == 1 && p[x].rela != p[y].rela)
            {
                sum++;
                continue;
            }
            if(d == 2 && ((3 - p[x].rela + p[y].rela) % 3 != d - 1))
            {
                sum++;
                continue;
                }
        }
    }
    printf("%d\n", sum);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wuswi0412/article/details/81482915