北京大学OpenJudge 1088:滑雪

1088:滑雪

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长的滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

输入

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

输出

输出最长区域的长度。

样例输入

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

样例输出

25

来源

Don't know

按照高度从小到大排序

1:排序

2:求递推顺序

3:初始值不容易设计,将所有点从小到大排序

源代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
const int maxn=100+10;
using namespace std;
struct node{
    int w,x,y;
    bool operator <(const node &b)const{
    return w<b.w;
    }
}node[maxn*maxn];
int p[maxn][maxn],f[maxn][maxn];
int main(){
    int r,c,cnt=0,ans=1;
    scanf("%d%d",&r,&c);
    for(int i=1;i<=r;i++){
        for(int j=1;j<=c;j++){
    scanf("%d",&p[i][j]);
    f[i][j]=1;
    node[cnt].w=p[i][j];
    node[cnt].x=i;
    node[cnt].y=j;
    cnt++;
        }
    }
    sort(node,node+cnt);
    for(int i=cnt-1;i>0;i--){
        int x=node[i].x;int y=node[i].y;
        if(x+1<=r&&p[x+1][y]<p[x][y]){
            f[x+1][y]=max(f[x+1][y],f[x][y]+1);
            ans=max(ans,f[x+1][y]);
        }
        if(x-1>=1&&p[x-1][y]<p[x][y]){
            f[x-1][y]=max(f[x-1][y],f[x][y]+1);
            ans=max(ans,f[x-1][y]);
        }
        if(y+1<=c&&p[x][y+1]<p[x][y]){
            f[x][y+1]=max(f[x][y+1],f[x][y]+1);
            ans=max(ans,f[x][y+1]);
        }
        if(y-1>=1&&p[x][y-1]<p[x][y]){
            f[x][y-1]=max(f[x][y-1],f[x][y]+1);
            ans=max(ans,f[x][y-1]);
        }
    }
    printf("%d\n",ans);

}

思路:这里用的是“我为人人”型的递推,我们可以用一个二维数组p[i][j]先存储输入的数据,我们用结构体node中的x和y去储存输入数据的横坐标还有纵坐标。随后用sort函数对node按照从小到大进行排序,之后的for循环:后面的点一定可以由前面的点转移而来,因为前面点的高度比后面的点要低,然后判断前面的点是否是后面点的相邻点,是的话就可以转移。

猜你喜欢

转载自blog.csdn.net/qq_37618760/article/details/81587694